Issue:
After connecting our Slack integration, it was disabled and we received an email from Torii with "The Slack integration to Torii has been disabled" as the subject.
The body of the email is as follows:
It is no longer allowing Torii access to your data - When using SCIM on an Enterprise Grid organization, the app must be installed on the organization, not individual workspaces.
Environment:
Using SCIM to provision users in Slack.
Cause:
The Torii app was installed at the Workspace level in Slack and not the Org level.
Resolution:
- Disconnect all Slack integrations in Torii.
- Uninstall the Torii app from Slack in your workspace. Instructions on doing that for the desktop client can be found here: https://slack.com/help/articles/360003125231-Remove-apps-and-custom-integrations-from-your-workspace
- Install the Torii app at your top-level Grid in Slack. Instructions here under 'Install an app at the org level': https://slack.com/help/articles/360000281563-Manage-apps-on-Enterprise-Grid
- Connect the Slack integration in Torii using the 'Enterprise Grid: Grid account' option for the 'Slack Plan type'. Connect it to your topmost grid in Slack.
- Connect an additional Slack integration in Torii using the 'Enterprise Grid: Workspace' option for the 'Slack Plan type'. Connect it to your workspace. If it gives you another error, please leave it connected so our engineers can check the integration.