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Technical Issue: After updating the Principal Name for a user in Azure, I get a "You cannot update or delete a read-only field" error message when provisioning via SCIM.

Andrew Bartel
Andrew Bartel
  • Updated

Issue:

After updating the Principal Name for a user in Azure, I get a "You cannot update or delete a read-only field" error message when provisioning via SCIM.

Screenshot 2023-08-03 at 4.46.33 PM.png

Environment:

Azure SCIM using the default attribute mapping of userPrincipalName to userName.

Cause:

The userName field in Torii cannot be changed or deleted once created. 

Resolution:

Delete the affected user(s) using the https://api.toriihq.com/v1.0/scim/v2/Users/{user_id} endpoint then provision the user again.

References:

  • https://support.toriihq.com/hc/en-us/articles/9183460072347-Torii-s-SCIM-User-Provisioning

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